Уразливість в CoBreeder

19:06 26.11.2008

09.05.2008

У березні, 29.03.2007, я знайшов Cross-Site Scripting уразливість в системі CoBreeder. Це система управління контентом (CMS).

Деталі уразливості з’являться пізніше, спочатку повідомлю розробникам системи.

26.11.2008

XSS:

http://site/%22style=%22xss:expression(alert(document.cookie))%22/*
Варіант для IE (можна також в усіх браузерах через onMouseOver) для сайтів на PHP <= 5.2.4.

http://site/"style="xss:expression(alert(document.cookie))"/*
Варіант для IE для сайтів на будь-яких версіях PHP.

На PHP > 5.2.4 дана уразливість працює лише в IE, коли посилати запит з лапками в ASCII, а не UTF-8 форматі (Mozilla і Firefox завжди конвертують запит в UTF-8). Що показали мої дослідження на декількох сайтах на CoBreeder з різними версіями PHP.

Атака з першим запитом може робити в залежності від версії PHP на веб сервері, другий запит є універсальним. XSS атака відбувається через PHP_SELF.

Уразлива версія coBreeder 2005 та попередні версії.


Leave a Reply

You must be logged in to post a comment.